Message: Compiling with QT using old Geant4 GNUMakefile build system Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Compiling with QT using old Geant4 GNUMakefile build system 

Forum: Installation and Configuration
Date: 29 Jan, 2015
From: Brent <Brent>

Hello,

I recently installed Geant4.10.01 on OS X.9 using the cmake system. Installation went smoothly and I'm able to build example applications. I installed with GDML on (xerces), Qt (4.8), and OpenGL (X11) using clang/++ 3.5.

However, when I attempt to use the old GNUmakefile build system from my geant4 installation share folder (e.g., <>/geant4.10.01-install/share/Geant4-10.1.0/geant4make/geant4make.sh), I get the following linker error:

ld: framework not found QtWidgets

Now, I see that QtWidgets is a Qt5 framework, not Qt 4. So I'm confused as to what on my system is requiring QtWidgets.

Any ideas are much appreciated.

Thanks, Brent

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Compiling with QT using old Geant4 GNUMakefile build system   (garnier - 09 Mar, 2015)
 Add Message Add Message
to: "Compiling with QT using old Geant4 GNUMakefile build system"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]