Message: Help: Low energy electromagnetic data are needed. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Help: Low energy electromagnetic data are needed. 

Forum: Installation and Configuration
Date: 28 Jan, 2015
From: Xiao Tong <Xiao Tong>

This error happened when I ran the B1 example after I installed the geant4.10.1 on my mac 10.10.1(yosemite) using cmake: Low energy electromagnetic data are needed. This is a NEW requirement for standard EM physics since geant4 9.5. Please set the environmental variable G4LEDATA to point to your G4EMLOW directory. Note: EMLOW6.23 or above is needed for Bremsstrahlung data. Data are available from the Geant4 download page.

Photon-evaporation data are needed. Please set the environmental variable G4LEVELGAMMADATA to point to your PhotonEvaporation directory. Data are available from the Geant4 download page.

*** Fatal error: Missing mandatory data for this simulation engine ***

*** Fatal Exception *** core dump *** -------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution *** Abort trap: 6

Anyone can tell me how to set the environmental variable on mac terminal? Many thanks. Jiang

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Help: Low energy electromagnetic data are needed.   (Ivan Brilkov - 05 Feb, 2015)
2 None: Re: Help: Low energy electromagnetic data are needed.   (Michael H. Kelsey - 06 Feb, 2015)
 Add Message Add Message
to: "Help: Low energy electromagnetic data are needed."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]