Message: Special program is giving installation problem in G4.10.00 (and not in G4.9.4) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Special program is giving installation problem in G4.10.00 (and not in G4.9.4) 

Forum: Installation and Configuration
Date: 14 Jul, 2014
From: Sezgin <Sezgin>

Dear Geant4 experts;
I have to install a program to use in my analysis. The program was installed before on G4 9.4 without problem.
I installed all needed programs (root 5.34.03, CLHEP 2.1.4.2, Geant4 10.00)
on my computer without problem.
The error is attached below.
Thanks in advance for your help and comment


$ make
Making dependency for file StopSim.cc ...
Making dependency for file src/StopSimTransferMessenger.cc ...
Making dependency for file src/StopSimTargetMessenger.cc ...
Making dependency for file src/StopSimSteppingMessenger.cc ...
Making dependency for file src/StopSimSteppingAction.cc ...
Making dependency for file src/StopSimStepMax.cc ...
Making dependency for file src/StopSimScaleNucDEDXMessenger.cc ...
Making dependency for file src/StopSimScaleElDEDXMessenger.cc ...
Making dependency for file src/StopSimRunAction.cc ...
Making dependency for file src/StopSimPrimaryGeneratorAction.cc ...
Making dependency for file src/StopSimPhysListEm.cc ...
Making dependency for file src/StopSimPhysicsListMessenger.cc ...
Making dependency for file src/StopSimPhysicsList.cc ...
Making dependency for file src/StopSimMaterialMessenger.cc ...
Making dependency for file src/StopSimMaterial.cc ...
Making dependency for file src/StopSimHistoMessenger.cc ...
Making dependency for file src/StopSimHisto.cc ...
Making dependency for file src/StopSimDetectorConstruction.cc ...
Making dependency for file src/StopSimCoulexMessenger.cc ...
Making dependency for file src/myG4IonParametrisedLossModel.cc ...
Making dependency for file src/G4TransferReaction.cc ...
Making dependency for file src/G4NuclearStopping.cc ...
Making dependency for file src/G4InelasticCoulombScattering.cc ...
Making dependency for file src/G4ICRU49NuclearStoppingModel.cc ...
Compiling G4ICRU49NuclearStoppingModel.cc ...
src/G4ICRU49NuclearStoppingModel.cc: In member function ‘void G4ICRU49NuclearStoppingModel::Init()’:
src/G4ICRU49NuclearStoppingModel.cc:89:22: error: ‘eV’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:89:22: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:157:24: note: ‘CLHEP::eV’
src/G4ICRU49NuclearStoppingModel.cc:89:25: error: ‘cm2’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:89:25: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:90:23: note: ‘CLHEP::cm2’
src/G4ICRU49NuclearStoppingModel.cc: In member function ‘virtual G4double G4ICRU49NuclearStoppingModel::ComputeDEDXPerVolume(const G4Material*, const G4ParticleDefinition*, G4double, G4double)’:
src/G4ICRU49NuclearStoppingModel.cc:122:45: error: ‘eplus’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:122:45: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:139:23: note: ‘CLHEP::eplus’
src/G4ICRU49NuclearStoppingModel.cc:124:16: error: ‘proton_mass_c2’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:124:16: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/PhysicalConstants.h:88:23: note: ‘CLHEP::proton_mass_c2’
src/G4ICRU49NuclearStoppingModel.cc:124:47: error: ‘MeV’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:124:47: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:156:23: note: ‘CLHEP::MeV’
src/G4ICRU49NuclearStoppingModel.cc:127:9: error: ‘amu_c2’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:127:9: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/PhysicalConstants.h:90:31: note: ‘CLHEP::amu_c2’
src/G4ICRU49NuclearStoppingModel.cc:137:35: error: ‘mole’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:137:35: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:248:23: note: ‘CLHEP::mole’
src/G4ICRU49NuclearStoppingModel.cc:137:40: error: ‘g’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:137:40: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:172:25: note: ‘CLHEP::g’
src/G4ICRU49NuclearStoppingModel.cc:146:49: error: ‘MeV’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:146:49: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:156:23: note: ‘CLHEP::MeV’
src/G4ICRU49NuclearStoppingModel.cc: In member function ‘void G4ICRU49NuclearStoppingModel::AddScalePoint(G4ThreeVector)’:
src/G4ICRU49NuclearStoppingModel.cc:159:69: warning: declaration of ‘Value’ shadows a member of 'this' [-Wshadow]
src/G4ICRU49NuclearStoppingModel.cc: In member function ‘G4double G4ICRU49NuclearStoppingModel::NuclearStoppingPower(G4double, G4double, G4double, G4double, G4double)’:
src/G4ICRU49NuclearStoppingModel.cc:250:35: error: ‘keV’ was not declared in this scope
src/G4ICRU49NuclearStoppingModel.cc:250:35: note: suggested alternative:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/SystemOfUnits.h:158:23: note: ‘CLHEP::keV’
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/PhysicalConstants.h: At global scope:
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Units/PhysicalConstants.h:79:21: warning: ‘CLHEP::electron_charge’ defined but not used [-Wunused-variable]
/home/sezgin/Geant4/geant4.10.0-install/include/Geant4/CLHEP/Random/Randomize.h:61:12: warning: ‘CLHEP::HepRandomGenActive’ defined but not used [-Wunused-variable]
make: *** [/home/sezgin/geant4_workdir/tmp/Linux-g++/StopSim/G4ICRU49NuclearStoppingModel.o] Error 1

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Special program is giving installation problem in G4.10.00 (and not in G4.9.4)   (Michael H. Kelsey - 14 Jul, 2014)
 Add Message Add Message
to: "Special program is giving installation problem in G4.10.00 (and not in G4.9.4)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]