Message: Geant4 can't find OpenGL after installation Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Geant4 can't find OpenGL after installation 

Forum: Installation and Configuration
Date: 11 Jul, 2014
From: <junhui.works@gmail.com>

Hi,

After installing Geant4 on a linux machine(SL6.5), I found I can't run it in graphic model, while it worked well in text model. Therefore I posted my question to the GUI sub-forum. Having followed suggestions there, unfortunately I still can't fix the problem. And John suggested me to ask around here.

I copied my latest post in the GUI sub-forum in the following and the link is here : http://hypernews.slac.stanford.edu/HyperNews/geant4/get/userinterface/112/1/1.html

Thanks !

Best, Junhui

**************** My latest post in GUI sub-forum ***************************

I've followed your suggestion(s) : started to re-install the geant4 again, in new created directories. The problem unfortunately is still same as before [2].

There is one thing I probably should mention a little bit also, which is during the re-building the geant4, I used this command which closed external "EXPAT"(this technique has been searched from this forum also). I have no clue if this "close" play a negative role to the OPENGL / QT or not.

Besides, I have one question : does SL6.5 include OPENGL internally or not ? If not, maybe I need do download and install it ?

Thanks !

Best, Junhui

[2]
You have successfully registered the following graphics systems.
Current available graphics systems are:
  ASCIITree (ATree)
  DAWNFILE (DAWNFILE)
  G4HepRep (HepRepXML)
  G4HepRepFile (HepRepFile)
  RayTracer (RayTracer)
  VRML1FILE (VRML1FILE)
  VRML2FILE (VRML2FILE)
  gMocrenFile (gMocrenFile)
[3] 
cmake -DCMAKE_INSTALL_PREFIX=/home/junhui/geantf/geantf_install /home/junhui/geantf/geant4.10.00.p02 -DGEANT4_INSTALL_DATA=ON -DGEANT4_USE_SYSTEM_EXPAT=OFF

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Geant4 can't find OpenGL after installation   (junhui.works@gmail.com - 11 Jul, 2014)
(_ Ok: Re: Geant4 can't find OpenGL after installation   (junhui.works@gmail.com - 11 Jul, 2014)
 Add Message Add Message
to: "Geant4 can't find OpenGL after installation"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]