Message: "undefined reference to 'G4FukuiRenderer::G4FukuiRenderer()'" and such like Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question "undefined reference to 'G4FukuiRenderer::G4FukuiRenderer()'" and such like 

Forum: Installation and Configuration
Date: 03 Jul, 2014
From: Richard Gillham Darnley <Richard Gillham Darnley>

Hi,

I have geant4.9.3.p02 installed on my 64bit ubuntu desktop. I have allowed g4 to build the Dwan and VRML drivers during the ./Configure -build stage.

But when I try to compile the application Mulassis I get several errors:

/home/richard/g4work/tmp/Linux-g++/mulassis/exe/mulassis.o: In function `G4VisExecutive::RegisterGraphicsSystems()': mulassis.cc:(.text._ZN14G4VisExecutive23RegisterGraphicsSystemsEv[_ZN14G4VisExecutive23RegisterGraphicsSystemsEv]+0x11a): undefined reference to `G4FukuiRenderer::G4FukuiRenderer()' mulassis.cc:(.text._ZN14G4VisExecutive23RegisterGraphicsSystemsEv[_ZN14G4VisExecutive23RegisterGraphicsSystemsEv]+0x19a): undefined reference to `G4VRML1::G4VRML1()' mulassis.cc:(.text._ZN14G4VisExecutive23RegisterGraphicsSystemsEv[_ZN14G4VisExecutive23RegisterGraphicsSystemsEv]+0x1ba): undefined reference to `G4VRML2::G4VRML2()' collect2: error: ld returned 1 exit status make: *** [/home/richard/g4work/bin/Linux-g++/mulassis] Error 1

I have no idea why this is happening, please can some one shed some light on this?

Cheers,

Richard

 Add Message Add Message
to: ""undefined reference to 'G4FukuiRenderer::G4FukuiRenderer()'" and such like"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]