Message: Re: What is the error of cmake 277? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: What is the error of cmake 277? 

Forum: Installation and Configuration
Re: Question What is the error of cmake 277? (Julien Zhu)
Date: 20 Jun, 2014
From: Ben Morgan <Ben Morgan>



On Thu, 19 Jun 2014 07:46:59 GMT, Julien Zhu wrote:
> HI guys,
> 
>    I am installing G4 4.10.00.p01 version. CLHEP has been done, but when i input the command
> cmake -DCMAKE_INSTALL_PREFIX= /home/medphys/geant4.10.00/install -DGEANT4_USE_SYSTEM_EXPAT=OFF /home/medphys/geant4.10.00/geant4.10.00.p01
> 
> it always shows the error below:
> 
> CMake Error at cmake/Modules/Geant4ConfigureConfigScript.cmake:277 (file):
>   file RELATIVE_PATH called with incorrect number of arguments
> Call Stack (most recent call first):
>   CMakeLists.txt:116 (include)
> 
> Could you please make me clear how to solve this problem? thanks a lot.
> 
> Julien
> 

If the space between the '-DCMAKE_INSTALL_PREFIX=' and the '/home/medphys/geant4.10.00/install' is not a typo, try removing it - i.e. the argument should read:

cmake -DCMAKE_INSTALL_PREFIX=/home/medphys/geant4.10.00/install -DGEANT4_USE_SYSTEM_EXPAT=OFF /home/medphys/geant4.10.00/geant4.10.00.p01

not

cmake -DCMAKE_INSTALL_PREFIX= /home/medphys/geant4.10.00/install -DGEANT4_USE_SYSTEM_EXPAT=OFF /home/medphys/geant4.10.00/geant4.10.00.p01

 Add Message Add Message
to: "Re: What is the error of cmake 277?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]