Message: Incompatible Libraries and Granular Libraries Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Incompatible Libraries and Granular Libraries 

Forum: Installation and Configuration
Date: 17 Jun, 2014
From: Eric Stevens <Eric Stevens>

I have recently installed Patch 01 for Geant4.10 and have come across multiple issues. These have been complicated by being handed code that I have been told worked before, but that won't compile for me.

When I installed the patch, I had granular libraries disabled (unset) of course, because it is my understanding that they are no longer supported. However, when I try to compile the code (using gmake), it always says: "Using granular libraries..." This will switch back to saying global if I use a version of Geant4.10 from before Patch 01 by changing the env.csh file and re-sourcing it, which in turn runs the geant4make.csh file specific to that installation. Any ideas on what to look for or how to specify to use global libraries? Could this be an artifact from before that is looking at some seemingly unrelated flag I haven't been able to track down myself?

Just using the original Geant4.10 also doesn't solve the problem, as ld then insists that the only G4Tree libraries it can find are both incompatible. It is currently told to look in both Geant4.10-install/lib(64)/ and Gean4.10-install/lib(64)/Geant4.10.00/Linux-g++/ .

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: Incompatible Libraries and Granular Libraries   (Ben Morgan - 18 Jun, 2014)
(_ None: Re: Incompatible Libraries and Granular Libraries   (erict7 - 18 Jun, 2014)
(_ Question: Re: Incompatible Libraries and Granular Libraries   (Ben Morgan - 20 Jun, 2014)
 Add Message Add Message
to: "Incompatible Libraries and Granular Libraries"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]