Message: include directory is missing a version suffix Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback include directory is missing a version suffix 

Forum: Installation and Configuration
Date: 15 Apr, 2014
From: <vinzenz>

Hi,

I think the include directory is missing a version suffix. All other directories seem to get a version suffix appended by default, thus allowing one to install different versions in the same install directory (e.g. the default /usr/local), but the default include directory is <prefix>/include/Geant4 without any version. So to install multiple versions of GEANT w/o overwriting the include-files one needs to manually specify different include-directories which than all have another Geant4 directory in them cointaining the actual header files. Is there any good reason for this? Cheers,

Vinzenz

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: include directory is missing a version suffix   (Morgan, Benjamin - 22 Apr, 2014)
2 None: Re: include directory is missing a version suffix   (Morgan, Benjamin - 22 Apr, 2014)
 Add Message Add Message
to: "include directory is missing a version suffix"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]