Message: datasets not found when running basic examples Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question datasets not found when running basic examples 

Forum: Installation and Configuration
Date: 19 Mar, 2014
From: Claudio <Claudio>

Hi, I have successfully installed Geant4 and after that I also downloaded the datafiles. Nevertheless when I try to build and install the example B1 (or other basic examples) I obtain the following error message.

*************************************************************
 Geant4 version Name: geant4-10-00-patch-01    (28-February-2014)
                      Copyright : Geant4 Collaboration
                      Reference : NIM A 506 (2003), 250-303
                            WWW : http://cern.ch/geant4
*************************************************************

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : PhysicsLists002
      issued by : G4DataQuestionaire

Low energy electromagnetic data are needed. This is a NEW requirement for standard EM physics since geant4 9.5. Please set the environmental variable G4LEDATA to point to your G4EMLOW directory. Note: EMLOW6.23 or above is needed for Bremsstrahlung data. Data are available from the Geant4 download page.

Photon-evaporation data are needed. Please set the environmental variable G4LEVELGAMMADATA to point to your PhotonEvaporation directory. Data are available from the Geant4 download page.

G4NEUTRONXS are needed. Please set the environmental variable G4NEUTRONXSDATA to point to your G4NEUTRONXS directory. Data are available from the Geant4 download page.

*** Fatal error: Missing mandatory data for this simulation engine ***

*** Fatal Exception *** core dump *** -------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution *** Aborted (core dumped)

However the data and the environment variable seem to be set properly. Where could the problem be?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: datasets not found when running basic examples   (Neil Fazel - 20 Mar, 2014)
1 Question: Re: datasets not found when running basic examples   (Claudio - 21 Mar, 2014)
1 None: Re: datasets not found when running basic examples   (Neil Fazel - 22 Mar, 2014)
... 3 Message(s)
2 Question: Re: datasets not found when running basic examples   (Claudio - 21 Mar, 2014)
2 Question: Re: datasets not found when running basic examples   (Ben Morgan - 21 Mar, 2014)
 Add Message Add Message
to: "datasets not found when running basic examples"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]