Message: Re: unsetting G4UI_USE_XM when using CMake Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: unsetting G4UI_USE_XM when using CMake 

Forum: Installation and Configuration
Re: Question unsetting G4UI_USE_XM when using CMake (Neil Fazel)
Re: Idea Re: unsetting G4UI_USE_XM when using CMake (Garnier Laurent)
Re: None Re: unsetting G4UI_USE_XM when using CMake (Neil Fazel)
Re: None Re: unsetting G4UI_USE_XM when using CMake (C Mos)
Date: 20 Mar, 2014
From: Neil Fazel <Neil Fazel>

On Thu, 20 Mar 2014 20:15:42 GMT, C Mos wrote:

<snip>
> Now I have to admit in my distribution I did not see G4UI_USE_XM flag
> when I use ccmake on my system. I don't not how to unset that precise
> flag. Guessing, I would probably unset it in my main function of my
> program:
<snip>

Hi Chris,

   Thanks for responding. I ran ccmake with exact same arguments as for cmake, i.e. path of my geant4
installation and path of my application source code, and just like in your case I saw no way to modify 
G4UI_USE_XM; I could only toggle WITH_GEANT4_UIVIS, without more fine-grained control of
environment variables. Toggling WITH_GEANT4_UIVIS off would give me an application with no UI and
no visualization; that's not what I want.

What DID WORK, however, was removing every trace of cmake having ever been used in my ...-build
directory (e.g. removing CMakeCache.txt), then making the following change in my CMakeLists.txt:

Replacing

  find_package(Geant4 REQUIRED ui_all vis_all)

with

  find_package(Geant4 REQUIRED ui_tcsh vis_opengl_x11)


then re-running cmake followed by make. The clean up seems to have been necessary.

The information here

http://geant4.web.cern.ch/geant4/UserDocumentation/UsersGuides/InstallationGuide/html/ch03s02.html

was of some help.

(With good, ol' gmake, all I had to do was 'export G4UI_USE_XM=', followed by 'gmake clean' and gmake.)

Neil

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: unsetting G4UI_USE_XM when using CMake   (John Allison - 21 Mar, 2014)
2 None: Re: unsetting G4UI_USE_XM when using CMake   (garnier - 21 Mar, 2014)
1 None: Re: unsetting G4UI_USE_XM when using CMake   (Neil Fazel - 21 Mar, 2014)
(_ Note: Re: unsetting G4UI_USE_XM when using CMake   (Ben Morgan - 23 Mar, 2014)
(_ None: Re: unsetting G4UI_USE_XM when using CMake   (garnier - 24 Mar, 2014)
 Add Message Add Message
to: "Re: unsetting G4UI_USE_XM when using CMake"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]