Message: Re: unsetting G4UI_USE_XM when using CMake Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: unsetting G4UI_USE_XM when using CMake 

Forum: Installation and Configuration
Re: Question unsetting G4UI_USE_XM when using CMake (Neil Fazel)
Re: Idea Re: unsetting G4UI_USE_XM when using CMake (Garnier Laurent)
Date: 20 Mar, 2014
From: Neil Fazel <Neil Fazel>

Hi Laurent,

 Thanks for the tip. When I edited CMakeLists.txt, I was just following the advice here:

http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1438/2.html

I thought that's the way to do it.

I really miss the days before CMake came along. I now seem to be spending as much time figuring out the 
arcane aspects of configuration management as I spend on doing science. The purported benefits of CMake
(e.g. easily switching between geant4 versions) don't seem to pan out when you actually try them.

http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1622/1/1/1/1/1/1.html


What's worse, users are being steered away from gmake, with legitimate gmake questions remaining 
unanswered:

http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1625.html

Neil

On Mar 20, 2014, at 4:10 AM, Garnier Laurent wrote:

> 
> *** Discussion title: Installation and Configuration
> 
> Hi, 
> 
> You don't need to touch the CMakeLists.txt file. For a complete list of
> Geant4 cmake options, you can run interactive version of cmake :
> "ccmake"
> 
> Laurent
> 
> -------------------------------------------------------------
> Visit this GEANT4 at hypernews.slac.stanford.edu message (to reply or unsubscribe) at: 
> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1627/1.html 


 [ MIME part of type text/html without a name stripped ]

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: unsetting G4UI_USE_XM when using CMake   (C Mos - 20 Mar, 2014)
1 Feedback: Re: unsetting G4UI_USE_XM when using CMake   (Neil Fazel - 20 Mar, 2014)
1 None: Re: unsetting G4UI_USE_XM when using CMake   (John Allison - 21 Mar, 2014)
2 None: Re: unsetting G4UI_USE_XM when using CMake   (garnier - 21 Mar, 2014)
... 3 Message(s)
2 Note: Re: unsetting G4UI_USE_XM when using CMake   (Ben Morgan - 21 Mar, 2014)
 Add Message Add Message
to: "Re: unsetting G4UI_USE_XM when using CMake"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]