Message: Re: geant4.10 on mac os 10.9.2 problem with QT visualizer Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: geant4.10 on mac os 10.9.2 problem with QT visualizer 

Forum: Installation and Configuration
Re: Question geant4.10 on mac os 10.9.2 problem with QT visualizer (Ian Postuma)
Date: 12 Mar, 2014
From: Ben Morgan <Ben Morgan>

On Tue, 11 Mar 2014 09:20:27 GMT, Ian Postuma wrote:
> Hei ! My installation works fine with OpenGl, but I'm having some
> trouble in the setup of the QT4.8 visualizer!
> 
> I had some problems with OpenGl too, but i found in an other post on
> this forum, that by simply modifying CMakeCache.txt geant4.10 compiled
> correctly. This because the Make configuration wasn't able to get the
> OPENGL_INCLUDE_DIR
> 
> OPENGL_INCLUDE_DIR:PATH=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/OpenGL.framework/Headers
> 
> So i thought that also the QT PATH was wrong but I didn't find anything
> that looked like an error... here i copied the error message shown in
> the terminal...
> 
> Scanning dependencies of target G4expat
> Scanning dependencies of target G4zlib
> Scanning dependencies of target G4clhep
> [  0%] [  0%] Building CXX object source/externals/expat/CMakeFiles/G4expat.dir/src/xmlrole.cc.o
> Building CXX object source/externals/expat/CMakeFiles/G4expat.dir/src/xmlparse.cc.o
> [  0%] Building CXX object source/externals/zlib/CMakeFiles/G4zlib.dir/src/adler32.cc.o
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:198:21: warning: 
>       unused parameter 'ptr' [-Wunused-parameter]
>         const char *ptr,
>                     ^
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:199:21: warning: 
>       unused parameter 'end' [-Wunused-parameter]
>         const char *end,
>                     ^
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:200:25: warning: 
>       unused parameter 'enc' [-Wunused-parameter]
>         const ENCODING *enc)
>                         ^
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:219:22: warning: 
>       unused parameter 'ptr' [-Wunused-parameter]
>          const char *ptr,
>                      ^
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:220:22: warning: 
>       unused parameter 'end' [-Wunused-parameter]
>          const char *end,
>                      ^
> /Users/zintinos/Documents/dottorato/geant4/geant4_10_00/source/externals/expat/src/xmlrole.cc:221:26: warning: 
>       unused parameter 'enc' [-Wunused-parameter]
>          const ENCODING *enc)
> ...
> ...
> ...
> 2 warnings generated.
> Linking CXX shared library ../../outputs/library/Darwin-clang/libG4interfaces.dylib
> ld: framework not found QtGui
> clang: error: linker command failed with exit code 1 (use -v to see invocation)
> make[2]: *** [outputs/library/Darwin-clang/libG4interfaces.dylib] Error 1
> make[1]: *** [source/interfaces/CMakeFiles/G4interfaces.dir/all] Error 2
>
> make: *** [all] Error 2
> 
> Thanks for the help ! cheers Ian
> 

It looks like QtGui has been "found" by CMake (otherwise the cmake step should have emitted an error) but the linker cannot locate it. Could you please post:

  • The CMake version you are using
  • The Xcode version
  • The CMakeCache.txt file generated in your build directory
  • The location of your Qt installation.

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: geant4.10 on mac os 10.9.2 problem with QT visualizer   (Ian Postuma - 12 Mar, 2014)
(_ Note: Re: geant4.10 on mac os 10.9.2 problem with QT visualizer   (Ben Morgan - 14 Mar, 2014)
(_ Ok: Re: geant4.10 on mac os 10.9.2 problem with QT visualizer   (Ian Postuma - 08 Apr, 2014)
 Add Message Add Message
to: "Re: geant4.10 on mac os 10.9.2 problem with QT visualizer"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]