Message: geant4-config assumes gawk? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None geant4-config assumes gawk? 

Forum: Installation and Configuration
Date: 17 Feb, 2014
From: Giuseppe Vacanti <Giuseppe Vacanti>

I'm installing Geant4.10.00 on Ubuntu. After compilation geant4-config --libs outputs something like this (note the awk error):

geant4.10.00-build> <path>/geant4.10.00/bin/geant4-config --libs awk: line 1: illegal reference to array array -L<path>/geant4.10.00/bin/../lib -lG4Tree -lG4FR -lG4GMocren -lG4visHepRep -lG4RayTracer -lG4VRML -lG4vis_management -lG4modeling -lG4interfaces -lG4persistency -lG4analysis -lG4error_propagation -lG4readout -lG4physicslists -lG4run -lG4event -lG4tracking -lG4parmodels -lG4processes -lG4digits_hits -lG4track -lG4particles -lG4geometry -lG4materials -lG4graphics_reps -lG4intercoms -lG4global -lG4clhep

The error goes away if I install gawk (apparently the default on Ubuntu is mawk, awk is symlinked to one or the other). The script geant4-config continues on error (missing set -e), and in this case I get the answer I want, but with --datasets I get an empty answer instead of the expected list.

Is gawk a requirement I have missed?

Cheers, Giuseppe

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: geant4-config assumes gawk?   (Ben Morgan - 18 Feb, 2014)
 Add Message Add Message
to: "geant4-config assumes gawk?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]