Message: OPENGL_INCLUDE_DIR error during install Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question OPENGL_INCLUDE_DIR error during install 

Forum: Installation and Configuration
Date: 24 Jan, 2014
From: MYTHRA VARUN NEMALLAPUDI <MYTHRA VARUN NEMALLAPUDI>

Hello:
        I am trying to install Geant4 using CMake. Here is what I typed-
cmake -DCMake_INSTALL_PREFIX=/Users/mahathi/Documents/Software/geant4.10.00-install -DGEANT4_USE_QT=ON -DGEANT4_USE_OPENGL_X11=ON /Users/mahathi/Documents/Software/geant4.10.00

At the end of configuration, it gives me the following error:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
OPENGL_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /Users/mahathi/Documents/Software/geant4.10.00/source/visualization/externals/gl2ps
   used as include directory in directory /Users/mahathi/Documents/Software/geant4.10.00/source/visualization/OpenGL

I checked X11, it is properly installed. The CMake file 'Geant4InterfaceOptions.cmake' seems to appropriately point the location of X11. I am not sure I understand where the problem is.

I would appreciate any help from the users.

Thank you!

Mythra

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: OPENGL_INCLUDE_DIR error during install   (John Allison - 24 Jan, 2014)
(_ None: Re: OPENGL_INCLUDE_DIR error during install   (MYTHRA VARUN NEMALLAPUDI - 24 Jan, 2014)
(_ None: Re: OPENGL_INCLUDE_DIR error during install   (John Allison - 24 Jan, 2014)
(_ Idea: Re: OPENGL_INCLUDE_DIR error during install   (Sam Blake - 09 Feb, 2014)
1 None: Re: OPENGL_INCLUDE_DIR error during install   (MYTHRA VARUN NEMALLAPUDI - 09 Feb, 2014)
1 Ok: Re: OPENGL_INCLUDE_DIR error during install   (Sam Blake - 09 Feb, 2014)
2 None: Re: OPENGL_INCLUDE_DIR error during install   (Pete Wu - 09 Feb, 2014)
1 None: Re: OPENGL_INCLUDE_DIR error during install   (Sam Blake - 09 Feb, 2014)
... 2 Message(s)
 Add Message Add Message
to: "OPENGL_INCLUDE_DIR error during install"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]