Message: Error: a G4MPI library compile in Geant4.9.6p02 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Error: a G4MPI library compile in Geant4.9.6p02 

Forum: Installation and Configuration
Date: 05 Dec, 2013
From: Takahiro Kanehira <Takahiro Kanehira>

Hi,

I tried to compile a G4MPI library in Genat4.9.6p02, and got the following error. Dose anybody know how to fix it?

/parallel/MPI/source/src/G4MPImanager.cc:348:12: error: 
      cast from pointer to smaller type 'unsigned int' loses
      information
    buff = unsigned(threadID);

 The following is my computer information.
 OS: OS X version 10.9
 MPI: OpenMPI
 Configured with:-with-gxx-include-dir=/usr/include/c++/4.2.1
 Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
 Target: x86_64-apple-darwin12.5.0
 Thread model: posix

if you need more info, please let me know!

Thank you!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Error: a G4MPI library compile in Geant4.9.6p02   (Matthew Lund - 19 Dec, 2013)
(_ None: Re: Error: a G4MPI library compile in Geant4.9.6p02   (Nick Patterson - 21 Jul, 2014)
 Add Message Add Message
to: "Error: a G4MPI library compile in Geant4.9.6p02"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]