Message: Re: cmake_policy error, while building X11 opengl drivers Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: cmake_policy error, while building X11 opengl drivers 

Forum: Installation and Configuration
Re: Question cmake_policy error, while building X11 opengl drivers (Leila Moghadasi)
Date: 21 Nov, 2013
From: Ben Morgan <Ben Morgan>

On Wed, 20 Nov 2013 06:34:55 GMT, Leila Moghadasi wrote:
> I successfully installed Geant4.9.6.p02 on my new system (ubuntu 12.04).
> However, when I wanted to build X11 opengl drivers, I received a linking
> error related to INTERFACE-LINK-LIBRARIES. I have attached the print
> screen. As recommended in the error description I set cmake_policy as
> follows in the cmakelists.txt under source/processes:
> 
> if(POLICY CMP0022) cmake_policy(SET CMP0022 NEW) endif()
> 
> The error still persists!

Which CMake version are you using? Note that we don't support Ubuntu, though as far as we know everything should work here. You also don't have the Xmu libraries or headers installed by the message emitted about these (there is a bug in the Geant4 cmake code for this, which'll be fixed in version 10, but the fact remains you don't have that part of X11 installed).

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: cmake_policy error, while building X11 opengl drivers   (Leila Moghadasi - 21 Nov, 2013)
 Add Message Add Message
to: "Re: cmake_policy error, while building X11 opengl drivers"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]