Message: cmake_policy error, while building X11 opengl drivers Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question cmake_policy error, while building X11 opengl drivers 

Forum: Installation and Configuration
Date: 19 Nov, 2013
From: Leila Moghadasi <Leila Moghadasi>

Hi Geant4 experts,

I successfully installed Geant4.9.6.p02 on my new system (ubuntu 12.04). However, when I wanted to build X11 opengl drivers, I received a linking error related to INTERFACE-LINK-LIBRARIES. I have attached the print screen. As recommended in the error description I set cmake_policy as follows in the cmakelists.txt under source/processes:

if(POLICY CMP0022) cmake_policy(SET CMP0022 NEW) endif()

The error still persists!

Your help to resolve this issue is much appreciated!

Cheers Leila

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2013/11/19/22.33-25963-m_2013-11-20_16.39.29.png

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: cmake_policy error, while building X11 opengl drivers   (Ben Morgan - 21 Nov, 2013)
(_ Ok: Re: cmake_policy error, while building X11 opengl drivers   (Leila Moghadasi - 21 Nov, 2013)
 Add Message Add Message
to: "cmake_policy error, while building X11 opengl drivers"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]