Message: installation problem with Qt and OPENGL (gluLookAt) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None installation problem with Qt and OPENGL (gluLookAt) 

Forum: Installation and Configuration
Date: 13 Nov, 2013
From: <gderosa@na.infn.it>

Hi!
I'm trying to install the version geant4.9.6.p02 on ubuntu (13.4).
I preliminary installed the following lib:

apt-get install build-essential

apt-get install freeglut3-dev glew-utils libglew1.6-dev libfreeimage-dev

apt-get install mesa-common-dev

apt-get install zlib1g-dev libgl1-mesa-dev

apt-get install xserver-xorg-dev x11proto-xinerama-dev
libx11-xcb-devlibqglviewer-qt4-2

apt-get install expat libexpat1-dev

apt-get install cmake

apt-get install libglu1-mesa-dev mesa-utils

apt-get install libssl-dev libssl0.9.8

apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui
libqt4-opengl libqt4-opengl-dev qt4-qmake libqt4-dev-bin libqt4-qt3support
libqt4-designer qt4-designer qt4-doc qt4-linguist-tools libqt4-xml
libqglviewer-qt4-2  libqglviewer-qt4-dev

apt-get install libxerces-c3.1 libxerces-c-dev libicu-dev

but at the end of make step at the level


[100%] Building CXX object
source/visualization/OpenGL/CMakeFiles/G4OpenGL.dir/src/G4OpenGLViewer.cc.o

 I get the following message:

/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/src/G4OpenGLViewer.cc:
In member function ‘virtual void G4OpenGLViewer::SetView()’:
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/src/G4OpenGLViewer.cc:297:47:
error: ‘gluLookAt’ was not declared in this scope
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/src/G4OpenGLViewer.cc:
In member function ‘void G4OpenGLViewer::Pick(GLdouble, GLdouble)’:
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/src/G4OpenGLViewer.cc:428:53:
error: ‘gluPickMatrix’ was not declared in this scope
In file included from
/home/fabrizia/Geant4/geant4.9.6.p02/source/global/management/include/G4PhysicalConstants.hh:27:0,
                 from
/home/fabrizia/Geant4/geant4.9.6.p02/source/global/management/include/globals.hh:70,
                 from
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/management/include/G4VViewer.hh:39,
                 from
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/include/G4OpenGLViewer.hh:38,
                 from
/home/fabrizia/Geant4/geant4.9.6.p02/source/visualization/OpenGL/src/G4OpenGLViewer.cc:37:
/home/fabrizia/Geant4/geant4.9.6.p02/source/externals/clhep/include/CLHEP/Units/PhysicalConstants.h:
At global scope:
/home/fabrizia/Geant4/geant4.9.6.p02/source/externals/clhep/include/CLHEP/Units/PhysicalConstants.h:79:21:
warning: ‘CLHEP::electron_charge’ defined but not used [-Wunused-variable]
make[2]: ***
[source/visualization/OpenGL/CMakeFiles/G4OpenGL.dir/src/G4OpenGLViewer.cc.o]
Errore 1
make[1]: *** [source/visualization/OpenGL/CMakeFiles/G4OpenGL.dir/all]
Errore 2
make: *** [all] Errore 2


Can you suggest how solve it??
Thanks a lot
Gianfranca

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: installation problem with Qt and OPENGL (gluLookAt)   (Ben Morgan - 13 Nov, 2013)
 Add Message Add Message
to: "installation problem with Qt and OPENGL (gluLookAt)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]