Message: Adding Qt support to Geant4.9.6 under VS2010 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Adding Qt support to Geant4.9.6 under VS2010 

Forum: Installation and Configuration
Date: 11 Nov, 2013
From: Ivan Brilkov <Ivan Brilkov>

Hi
I'm trying to add Qt visualization to N03 because OGL visualization doesn't show detector configuration only particle tracks(I decided that it is driver problem, but video driver update doesn't make sense). 

CMAKE found Qt 4.8.5, and re-build of GEANT is already done, but when I try to build N03 with G4UI_USE option It says that available UI sessions only Win32, GAG and csh. 

As I consider all needed env variable is set:
path:
d:\Qt\4.8.5\bin
C:\Program Files\NVIDIA Corporation\PhysX\Common
C:\WINDOWS\system32
C:\WINDOWS
C:\WINDOWS\system32\WBEM
C:\Program Files\WinAVR\bin
C:\Program Files\WinAVR\utils\bin
c:\matlab6p5\bin\win32
C:\Program Files\Common Files\HP\Digital Imaging\bin
C:\Program Files\HP\Digital Imaging\bin\
C:\Program Files\HP\Digital Imaging\bin\Qt\Qt 4.3.3
C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\
C:\WINDOWS\system32\WindowsPowerShell\v1.0
D:\Geant4\geant4_9_6-install\bin
D:\Geant4\geant4_9_6\outputs\runtime\Release
C:\Program Files\Common Files\HP\Digital Imaging\bin
C:\Program Files\HP\Digital Imaging\bin\
C:\Program Files\HP\Digital Imaging\bin\Qt\Qt 4.3.3
D:\GeantShare\xerces\xerces-c-3.1.1-x86-windows-vc-10.0\bin


After reading several threads in this forum I've add a check for Qt to N03 CMakeList.txt(find_package(Geant4 REQUIRED COMPONENTS qt))
 and build says:

1>  CMake Error at D:/Geant4/geant4_9_6-install/lib/Geant4-9.6.2/Geant4Config.cmake:473 (message):
1>    Geant4 component qt not found
1>  Call Stack (most recent call first):
1>    CMakeLists.txt:21 (find_package)

How can I understand that Geant4 build with Qt support?
Thanks a lot!
Ivan Brilkov

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ben Morgan - 12 Nov, 2013)
1 None: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ivan Brilkov - 12 Nov, 2013)
(_ None: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ivan Brilkov - 14 Nov, 2013)
2 None: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ivan Brilkov - 02 Mar, 2014)
1 Note: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ben Morgan - 03 Mar, 2014)
2 Ok: Re: Adding Qt support to Geant4.9.6 under VS2010   (Ivan Brilkov - 05 Mar, 2014)
 Add Message Add Message
to: "Adding Qt support to Geant4.9.6 under VS2010"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]