Message: Re: G4LEND installation and preconfigured data Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: G4LEND installation and preconfigured data 

Forum: Installation and Configuration
Re: Question G4LEND installation and preconfigured data (William Donahue)
Date: 22 Oct, 2013
From: Garnier Laurent <Garnier Laurent>

Hi, 

G4LEDATA should point to the correct directory and the correct version. Check that it is really the case and version is EMLOW6.23 or above.
For example : G4LEDATA=/usr/local/share/Geant4-9.6.2/data/G4EMLOW6.32

Cheers, 
Laurent

Le 9 oct. 2013 à 16:29, William Donahue <willdonahue@snet.net> a écrit :

> 
> *** Discussion title: Installation and Configuration
> 
> Hi guys,
> 
> I am a new user trying to install Geant4 for some medical research. I am
> currently having 2 issues.
> 
> 1) I would like to include the G4LEND data into my Geant4 build. This is
> necessary for the work I will be doing. I can't seem to figure out or
> find any information on how that is accomplished. If you guys could
> point me in the correct direction that would be great
> 
> 2) I also have what I guess is a more pressing problem. I have complied
> geant4 using cmake with the GEANT4_INSTALL_DATA flag set to ON. However
> when I try to compile basic examples I get the following error
> 
> *************************************************************
> Geant4 version Name: geant4-09-06-patch-02 (17-May-2013)
>                      Copyright : Geant4 Collaboration
>                      Reference : NIM A 506 (2003), 250-303
>                            WWW : http://cern.ch/geant4
> *************************************************************
> 
> 
> -------- EEEE ------- G4Exception-START -------- EEEE -------
> *** G4Exception : PhysicsLists002
>      issued by : G4DataQuestionaire
> 
> Low energy electromagnetic data are needed.
> This is a NEW requirement for standard EM physics since geant4 9.5.
> Please set the environmental variable G4LEDATA
> to point to your G4EMLOW directory.
> Note: EMLOW6.23 or above is needed for Bremsstrahlung data.
> Data are available from the Geant4 download page.
> 
> Photon-evaporation data are needed.
> Please set the environmental variable G4LEVELGAMMADATA
> to point to your PhotonEvaporation directory.
> Data are available from the Geant4 download page.
> 
> G4NEUTRONXS are needed.
> Please set the environmental variable G4NEUTRONXSDATA
> to point to your G4NEUTRONXS directory.
> Data are available from the Geant4 download page.
> 
> *** Fatal error: Missing mandatory data for this simulation engine ***
> 
> *** Fatal Exception *** core dump ***
> -------- EEEE -------- G4Exception-END --------- EEEE -------
> 
> 
> *** G4Exception: Aborting execution ***
> Aborted
> 
> The data is in the proper install areas. I have also set those
> enviormental variables using the env command prior to running the
> script. Any help here would also be appreciated.
> 
> Thanks guys in advance for your help.
> 
> System: Scientific Linux 6.4
> 
> -------------------------------------------------------------
> Visit this GEANT4 at hypernews.slac.stanford.edu message (to reply or unsubscribe) at: 
> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1581.html 


 [ MIME part of type text/html without a name stripped ]

 Add Message Add Message
to: "Re: G4LEND installation and preconfigured data"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]