Message: Help with Installation on Windows and Linus (Ubuntu) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Help with Installation on Windows and Linus (Ubuntu) 

Forum: Installation and Configuration
Date: 21 Aug, 2013
From: ANUSIONWU Princess <ANUSIONWU Princess>

Hello All,

I am a new Geant4 user and having issues with installing it on both Windows and Linux OS

On WINDOWS: Following the instructions on 2.2. Building and Installing on Windows Platforms (of the bookinstallguide), the steps were successfully executed up to step 12. I see Build failed. I have tried running the steps over and over again but I still get build failed.

On LINUX: The build was successful but when I try running example B1, the final command:

$ ./exampleB1 (page 22 of the bookinstallguide)

gives the error that some data are required to build this example. I re-run cmake and set the GEANT4_INSTALL_DATA variable to ON: (page 5 of the bookinstallguide) and got the reply:

-- The following Geant4 features are enabled: GEANT4_BUILD_CXXSTD: Compiling against C++ Standard 'c++98' GEANT4_USE_SYSTEM_EXPAT: Using system install of EXPAT -- Configuring done -- Generating done -- Build files have been written to: /path/to/geant4.9.6-build

when I try building example B1 again, I still get the error message that some data are needed to build it.

Any urgent help will be appreciated please. Thank you.

Princess

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Help with Installation on Windows and Linus (Ubuntu)   (John Allison - 22 Aug, 2013)
 Add Message Add Message
to: "Help with Installation on Windows and Linus (Ubuntu)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]