Message: Re: Geant4 vs. GPL licence: conflicting or not? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4 vs. GPL licence: conflicting or not? 

Forum: Installation and Configuration
Re: Question Geant4 vs. GPL licence: conflicting or not? (Mojca Miklavec)
Re: Warning Re: Geant4 vs. GPL licence: conflicting or not? (Ben Morgan)
Date: 15 Aug, 2013
From: Joseph Perl <Joseph Perl>

On Thu, 15 Aug 2013 13:49:51 GMT, Ben Morgan wrote:
> On Thu, 15 Aug 2013 13:01:42 GMT, Mojca Miklavec wrote:
> > Hi,
> > 
> > I would like a confirmation of whether or not Geant4 licence conflicts
> > with GPL-2 and/or 3.

Geant4 has its own license. It is not a GPL license. The license is included in the top directory of the Geant4 source and is mirrored at: http://geant4.web.cern.ch/geant4/license/LICENSE.html

Geant4 does not depend on any GPL code. We have been careful to avoid this, as we have not wanted the GPL license to contaminate the Geant4 license.

As an end user, or as the maker of some intermediate product that depends on Geant4 (a macports build is such an intermediate product), it is up to you to insure that you do not violate any licenses. It is not up to the Geant4 collaboration to monitor such activity.

 Add Message Add Message
to: "Re: Geant4 vs. GPL licence: conflicting or not?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]