Message: Geant4 vs. GPL licence: conflicting or not? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Geant4 vs. GPL licence: conflicting or not? 

Forum: Installation and Configuration
Date: 15 Aug, 2013
From: Mojca Miklavec <Mojca Miklavec>

Hi,

I would like a confirmation of whether or not Geant4 licence conflicts with GPL-2 and/or 3.

Geant4 depends on Root which may depend on GSL (GPL-3+) and graphviz->GTS->JBIG-KIT (GPL-2+). It may also depend on iAIDA->grace->pdflib with a restrictive licence.

I would like to see binary packages in MacPorts because it takes a lot of time to compile Geant4, but I'm not sure if they are allowed or not (or if iAIDA, graphviz and gsl all need to be disabled to allow binary distributability).

Also, I have no idea how to disable dependency on iAIDA (if iAIDA is found on the system, I have no idea how to prevent its use in Geant4 / what CMake option could be used to disable it).

Thank you,
    Mojca

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: Geant4 vs. GPL licence: conflicting or not?   (Ben Morgan - 15 Aug, 2013)
(_ None: Re: Geant4 vs. GPL licence: conflicting or not?   (Joseph Perl - 15 Aug, 2013)
 Add Message Add Message
to: "Geant4 vs. GPL licence: conflicting or not?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]