Message: aida-config doesn't recognize --implementation Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning aida-config doesn't recognize --implementation 

Forum: Installation and Configuration
Date: 28 Jun, 2013
From: Mojca Miklavec <Mojca Miklavec>

I'm trying to create an experimental package of Geant4 10.0 for MacPorts.

But I had to comment out part of the code in cmake/Modules/FindAIDA.cmake because aida-config doesn't know the option --implementation:

      execute_process(
        COMMAND ${AIDA_CONFIG_EXECUTABLE} --implementation
        OUTPUT_VARIABLE AIDA_IMPLEMENTATION
        OUTPUT_STRIP_TRAILING_WHITESPACE)

It fails with:

    Traceback (most recent call last):
      File "/opt/local/bin/aida-config", line 266, in <module>
        ['help', 'version', 'includes', 'cflags', 'libs', 'runtime=', 'platform='])
      File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 88, in getopt
        opts, args = do_longs(opts, args[0][2:], longopts, args[1:])
      File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 152, in do_longs
        has_arg, opt = long_has_args(opt, longopts)
      File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 169, in long_has_args
        raise GetoptError('option --%s not recognized' % opt, opt)
    getopt.GetoptError: option --implementation not recognized

Is there any version of AIDA that supports this option? I have AIDA version 3.2.1 installed via MacPorts under Mac OS X 10.7. I commented out the code as a temporary workaround.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: aida-config doesn't recognize --implementation   (Andreas Pfeiffer - 07 Jul, 2013)
2 None: Re: aida-config doesn't recognize --implementation   (Ivana Hrivnacova - 08 Jul, 2013)
1 None: Re: aida-config doesn't recognize --implementation   (Andreas Pfeiffer - 08 Jul, 2013)
 Add Message Add Message
to: "aida-config doesn't recognize --implementation"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]