Message: Re: Undefined Qt, Unexpected token Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: Undefined Qt, Unexpected token  

Forum: Installation and Configuration
Re: Question Undefined Qt, Unexpected token "(" and hang while running example B1 (fatin hamimi mustafa)
Date: 28 Jun, 2013
From: Ben Morgan <Ben Morgan>

On Mon, 24 Jun 2013 22:19:39 GMT, fatin hamimi mustafa wrote:
> 1) The first problem is can't find Qt4
> 
> cmake -DCMAKE_INSTALL_PREFIX=/users/abc/geant4.9.6-install
> -DGEANT4_USE_OPENGL_X11=ON -DGEANT4_USE_RAYTRACER_X11=ON
> -DQT_QMAKE_EXECUTABLE=/users/abc/qt/bin/qmake -DGEANT4_USE_QT=ON
> /applications/geant4.9.6

What version of Qt does qmake report, i.e. what is the output of /users/abc/qt/bin/qmake -v? On an OS X system, I'd strongly recommend using the Qt 4.8 Libraries DMG supplied by the Qt Project.

> 2) Unexpected token while key in source geant4.csh
> 
> 192-168-1-12:bin abc$ cd /users/abc/geant4.9.6-install/bin ; source
> geant4.csh -bash: /users/abc/geant4.9.6-install/bin/geant4.csh: line 24:
> syntax error near unexpected token `(' -bash:
> /users/abc/geant4.9.6-install/bin/geant4.csh: line 24: `set ARGS=($_)'

You're trying to source a C-shell script in a bash shell session - try geant4.sh instead.

> 3) I also had problem with visualisation installation. Eventhough I
> already enable -DGEANT4_USE_OPENGL_X11 (the command as in no 1),
> suddenly it went hang after tried example B1. No 'Idle' word appeare to
> key in. (Due to error of enabling -DGEANT4_USE_QT because of Qt version
> is not found, then I just enabled -DGEANT4_USE_OPENGL_X11 and
> -DGEANT4_USE_TRAYTRACER_X11 only )

As per John's comment, you'll need to run a debugger and check the output of that.

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Undefined Qt, Unexpected token   (fatin hamimi mustafa - 29 Jun, 2013)
 Add Message Add Message
to: "Re: Undefined Qt, Unexpected token "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]