Message: Re: Qt5 problem Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Idea Re: Qt5 problem 

Forum: Installation and Configuration
Re: Question Qt5 problem (Leonardo Ghizoni)
Date: 16 May, 2013
From: Zach Hartwig <Zach Hartwig>

Hi Leonardo,

I can't speak for the Geant4 build team so I don't know if they have plans to upgrade to Qt 5.0 in the near future.

In order to build Geant4 on your system, you'll have to download the Qt 4.0 libraries (most recent is Qt 4.8.4) and build them before you build Geant4. The libraries are available here: http://qt-project.org/downloads

I suggest download the tar.gz file and building Qt from source. Instructions for building on X11 platforms can be found here: http://qt-project.org/doc/qt-4.8/install-x11.html

If you install Qt somewhere other than the usual places (/usr/lib, /usr/local, etc) that are not in your path, please be sure to use the CMake variables for setting the path to your Qt installation.

Hope this helps.

~ZSH

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Qt5 problem   (garnier - 17 May, 2013)
(_ Ok: Re: Qt5 problem   (Leonardo Ghizoni - 17 May, 2013)
 Add Message Add Message
to: "Re: Qt5 problem"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]