|Message: unmet dependencies||Not Logged In (login)|
Click on the Forum title, e.g. on the "Forums by Category" page, to read a sequence of postings to the Forum and its threads all in one page. If you are only interested in one thread or the thread following a specific posting, click the thread or the posting, which takes you to a smaller page, which contains only the part you are interested in and may be easier to navigate.
Messages are "chained" if there are only replies at the first level, i.e. 1/1.html, 1/1/1.html etc. In case of "chained" messages the message number is replaced by the icon and there is no indentation.
Inline: Display the subject line only or also the text of the posting(s); for the choice "All" the "Outline" choices are switched off.
|1||0||1||no text / full text of posting|
|2||1||All||text for level 1 only / text for All postings|
Outline: Choose the depth of the posting thread, successive toggle controls provide increasing detail.
|1||2||1||2 levels / 1 level (original posting)|
|2||3||2||3 levels / 2 levels|
|3||3||All||3 levels / all levels (all postings)|
I am trying to install geant4 with the repository of http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian/index.php into ubuntu 12.04 (32bit).
I have added the lines of deb http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep deb-src http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep to /etc/apt/sources.list and done sudo apt-get install cern-archive-keyring. sudo apt-get update sudo apt-get dist-upgrade
When I enter sudo apt-get install geant4,
errors come out with the messages of ------------- The following packages have unmet dependencies: geant4 : Depends: libgeant4-dev but it is not going to be installed Depends: libgeant4-plists-dev but it is not going to be installed Depends: libg4opengl-dev but it is not going to be installed Depends: geant4-examples but it is not going to be installed E: Unable to correct problems, you have held broken packages. --------------- Following the messages above, I entered like sudo apt-get install libgeant4-dev libgeant4-plists-dev libg4opengl-dev geant4-examples geant4
but, other errors appeared; ------------- The following packages have unmet dependencies: geant4-examples : Depends: libgeant4-dev (>= 4.9.4.p02) but 4.9.3.p02-1 is to be installed libgeant4-dev : Depends: geant4-headers (< 4.9.3.p02.0~) but 4.9.4.p02-1 is to be installed E: Unable to correct problems, you have held broken packages. -------------
Since the versions of geant4-examples and libgeant4-headers are 4.9.4.p02-1, I suspect that only libgeant4-dev, of which the version is 4.9.3.p02-1, is too old.
Can administrator update the repository or anyone tell me any solutions to avoid the errors?
|Inline Depth:||Outline Depth:||Add message:|