Message: unmet dependencies Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question unmet dependencies 

Forum: Installation and Configuration
Date: 09 May, 2013
From: Yoshihiro Shimbara <Yoshihiro Shimbara>

I am trying to install geant4 with the repository of
 http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian/index.php
into ubuntu 12.04 (32bit).

I have added the lines of
 deb http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep
 deb-src http://lcg-heppkg.web.cern.ch/lcg-heppkg/debian stable hep
to /etc/apt/sources.list and done
 sudo apt-get install cern-archive-keyring.
 sudo apt-get update
 sudo apt-get dist-upgrade

When I enter
 sudo apt-get install geant4,

errors come out with the messages of
-------------
The following packages have unmet dependencies:
 geant4 : Depends: libgeant4-dev but it is not going to be installed
          Depends: libgeant4-plists-dev but it is not going to be installed
          Depends: libg4opengl-dev but it is not going to be installed
          Depends: geant4-examples but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
---------------
Following the messages above, I entered like
 sudo apt-get install libgeant4-dev libgeant4-plists-dev libg4opengl-dev geant4-examples geant4

but, other errors appeared;
-------------
The following packages have unmet dependencies:
 geant4-examples : Depends: libgeant4-dev (>= 4.9.4.p02) but 4.9.3.p02-1 is to be installed
 libgeant4-dev : Depends: geant4-headers (< 4.9.3.p02.0~) but 4.9.4.p02-1 is to be installed
E: Unable to correct problems, you have held broken packages.
-------------

Since the versions of geant4-examples and libgeant4-headers are 4.9.4.p02-1, I suspect that only libgeant4-dev, of which the version is 4.9.3.p02-1, is too old.

Can administrator update the repository or anyone tell me any solutions to avoid the errors?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: unmet dependencies   (Ben Morgan - 10 May, 2013)
(_ Ok: Re: unmet dependencies   (Yoshihiro Shimbara - 13 May, 2013)
(_ Idea: Re: unmet dependencies   (Leonardo Ghizoni - 16 May, 2013)
(_ Ok: Re: unmet dependencies   (Yoshihiro Shimbara - 09 Jun, 2013)
 Add Message Add Message
to: "unmet dependencies"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]