Message: Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10 

Forum: Installation and Configuration
Re: None OpenGL visualization error Geant4.9.6 Ubuntu 12.10 (Evgenia Tokareva)
Date: 06 Mar, 2013
From: Ben Morgan <Ben Morgan>

Hi Evgenia,

On Wed, 06 Mar 2013 07:21:08 GMT, Evgenia Tokareva wrote:
> although, I have set the following
> 
> cmake -DCMAKE_INSTALL_PREFIX=~/GEANT/geant-install
> -DGEANT4_INSTALL_DATA=ON -DGEANT_USE_OPENGL_X11= ON ~/GEANT/geant4.9.6
>                                                 ^---- literal space?

If you have a literal space in the -D argument as I've highlighted, then cmake will have interpreted the space instead of the ON. If OpenGL/X11 is activated correctly, then you should see output at the end of the run of cmake that reads:

-- The following Geant4 features are enabled:
GEANT4_BUILD_CXXSTD: Compiling against C++ Standard 'c++98'
GEANT4_USE_SYSTEM_EXPAT: Using system EXPAT library
GEANT4_USE_OPENGL_X11: Build Geant4 OpenGL driver with X11 support

-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/g4test

NB - the path in the last line is specific to my machine. If you haven't got the line reading GEANT4_USE_OPENGL_X11, then OpenGL/X11 won't be built. As you don't have libG4OpenGL in your library install directory, I would try rerunning cmake and ensuring that you remove the literal space as highlighted above. That should hopefully fix things!

> My lib folder (and also /usr/local/lib) contains following files, I
> suppose there must be also (.a) files. How to generate them? Will it
> solve the problem?

If you want static libraries as well as shared, add the argument -DBUILD_STATIC_LIBS=ON to cmake when configuring. This won't solve the issue reported above, but that's how to activate their build if you want them.

Hope that helps,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10   (Evgenia Tokareva - 06 Mar, 2013)
(_ None: Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10   (Ben Morgan - 06 Mar, 2013)
(_ None: Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10   (Evgenia Tokareva - 06 Mar, 2013)
 Add Message Add Message
to: "Re: OpenGL visualization error Geant4.9.6 Ubuntu 12.10"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]