Message: Re: Compiling application doesn't build executable Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Compiling application doesn't build executable 

Forum: Installation and Configuration
Re: None Compiling application doesn't build executable (Bethany)
Date: 25 Feb, 2013
From: Ben Morgan <Ben Morgan>

Hi Bethany,

Some brief comments below,

On Mon, 25 Feb 2013 16:42:17 GMT, Bethany wrote:
> username@cobalt01 ~/g4work/simulations/DMIceSim-build $ make -j1 [ 3%]
> Built target G4clhep [ 4%] Built target G4global [ 5%] Built target
> G4intercoms [ 5%] Built target G4analysis [ 5%] Built target G4materials
> [ 6%] Built target G4graphics_reps [ 15%] Built target G4geometry [ 21%]
> Built target G4particles [ 21%] Built target G4track [ 24%] Built target
> G4digits_hits [ 24%] Built target G4expat [ 80%] Built target
> G4processes [ 81%] Built target G4tracking [ 82%] Built target G4event [
> 83%] Built target G4run [ 84%] Built target G4error_propagation [ 85%]
> Built target G4interfaces [ 85%] Built target G4parmodels [ 87%] Built
> target G4persistency [ 93%] Built target G4physicslists [ 93%] Built
> target G4readout [ 95%] Built target G4modeling [ 96%] Built target
> G4vis_management [ 96%] Built target G4FR [ 96%] Built target G4zlib [
> 97%] Built target G4visHepRep [ 98%] Built target G4RayTracer [ 98%]
> Built target G4Tree [ 98%] Built target G4VRML [ 98%] Built target
> G4visXXX [ 98%] Built target G4gl2ps [ 98%] Built target G4GMocren
> [100%] Built target G4OpenGL

For an application built against an install or even uninstalled build of Geant4, you shouldn't be seeing reports on Geant4 targets being built. Where is your Geant4 build/install directory in relation to the source/build directories of your application? It looks like there is some blending or otherwise.

> (my understanding is that the last "built target" statement should be my
> executable (dmicesimm), but it is not here.)
> 
>    Attachment:
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2013/02/25/08.41-10560-CMakeLists.rtf
> 

The only thing I can see here is that you have absolute paths and also a reference by the look of things to a 9.5.p01 install. Whether these have an effect I don't know.

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Compiling application doesn't build executable   (Bethany - 28 Feb, 2013)
1 None: Re: Compiling application doesn't build executable   (Ben Morgan - 01 Mar, 2013)
2 None: Re: Compiling application doesn't build executable   (Bethany - 01 Mar, 2013)
2 None: Re: Compiling application doesn't build executable   (Ben Pietras - 04 Oct, 2014)
1 None: Re: Compiling application doesn't build executable   (Ben Pietras - 04 Oct, 2014)
(_ None: Re: Compiling application doesn't build executable   (Ben Pietras - 04 Oct, 2014)
 Add Message Add Message
to: "Re: Compiling application doesn't build executable"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]