Message: OpenGL in windows with 9.6p01 crashes Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None OpenGL in windows with 9.6p01 crashes 

Forum: Installation and Configuration
Date: 24 Feb, 2013
From: Witold Matysiak <Witold Matysiak>

Hello,

I've recently upgraded from G4.9.5p02 to G4.9.6p01 and I'm having issues with visualization with OpenGL. G4 shows this message:

G4OpenGLViewer::DrawText: Not implemented for "viewer-0 (OpenGLStoredWin32)" plus some other text, but no obvious error message. And then G4 crashes.

When in debugging mode, it crashes in e.g. SetGuidance() method of a messenger class. When SetGuidance is commented out, it crashes when building a factory physics list.

Without visualization runs fine. I tried it with my own application as well as exampleB1.

I'm running Windows 7 32 bit. G4 was built with cmake and compiled with VC++ 2010. Any clues?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: OpenGL in windows with 9.6p01 crashes   (John Allison - 25 Feb, 2013)
(_ None: Re: OpenGL in windows with 9.6p01 crashes   (Witold Matysiak - 25 Feb, 2013)
(_ None: Re: OpenGL in windows with 9.6p01 crashes   (Witold Matysiak - 25 Feb, 2013)
1 None: Re: OpenGL in windows with 9.6p01 crashes   (garnier - 26 Feb, 2013)
1 None: Re: OpenGL in windows with 9.6p01 crashes   (Witold Matysiak - 26 Feb, 2013)
... 5 Message(s)
2 None: Re: OpenGL in windows with 9.6p01 crashes   (John Allison - 12 Jun, 2013)
1 None: Re: OpenGL in windows with 9.6p01 crashes   (Witold Matysiak - 25 Jun, 2013)
 Add Message Add Message
to: "OpenGL in windows with 9.6p01 crashes"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]