Message: error building GEANT4.9.6 with visual studio - Windows 7 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question error building GEANT4.9.6 with visual studio - Windows 7 

Forum: Installation and Configuration
Date: 17 Jan, 2013
From: Evelyn <Evelyn >

Hi,

I am in a similar situation to Amy - when i try to build GEANT4 in the Debug configuration i get the same error message - "may need admin privileges"

So I tried installing in a different directory and with/without administrator privileges but nothing works. Only half build OK without administrator privileges while nearly nothing builds (only 2 successful) with administrator privileges(?!?! even more strange).

I have run out of ideas of what to try, any suggestion?? I get long lists of error as shown below...

Thanks!! Evelyne

2>------ Build started: Project: G4clhep, Configuration: Release Win32 ------
2>     Creating library C:/Users/meiere/Documents/geant4/geant4_9_6-buid/outputs/archive/Release/G4clhep.lib and object C:/Users/meiere/Documents/geant4/geant4_9_6-buid/outputs/archive/Release/G4clhep.exp
2>G4clhep.exp : error LNK2001: unresolved external symbol "public: __thiscall std::allocator<struct std::_Container_proxy>::allocator<struct std::_Container_proxy><char>(class std::allocator<char> const &)" (??$?0D@?$allocator@U_Container_proxy@std@@@std@@QAE@ABV?$allocator@D@1@@Z)
...
2>G4clhep.exp : error LNK2001: unresolved external symbol "public: void __thiscall std::allocator<struct std::_Container_proxy>::destroy(struct std::_Container_proxy *)" (?destroy@?$allocator@U_Container_proxy@std@@@std@@QAEXPAU_Container_proxy@2@@Z)
2>G4clhep.exp : error LNK2001: unresolved external symbol "public: static unsigned int const std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >::npos" (?npos@?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@2IB)
2>C:\Users\meiere\Documents\geant4\geant4_9_6-buid\outputs\runtime\Release\G4clhep.dll : fatal error LNK1120: 63 unresolved externals

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: error building GEANT4.9.6 with visual studio - Windows 7   (Evelyn - 17 Jan, 2013)
1 None: Re: error building GEANT4.9.6 with visual studio - Windows 7   (Evelyn - 17 Jan, 2013)
2 Question: Re: error building GEANT4.9.6 with visual studio - Windows 7   (Ben Morgan - 21 Jan, 2013)
1 Ok: Re: error building GEANT4.9.6 with visual studio - Windows 7   (Evelyn - 22 Jan, 2013)
2 None: Re: error building GEANT4.9.6 with visual studio - Windows 7   (Jackie Jing - 01 Feb, 2013)
 Add Message Add Message
to: "error building GEANT4.9.6 with visual studio - Windows 7"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]