Message: Re: Error when linking to CLHEP library Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Error when linking to CLHEP library 

Forum: Installation and Configuration
Re: Question Error when linking to CLHEP library
Re: Question Re: Error when linking to CLHEP library (Ben Morgan)
Date: 10 Jan, 2013
From: <miambrose>

> * How are you building your application - with Geant4Make or CMake?

I am using cmake version 2.6-patch 4.

> * What environment variables do you have set, specifically those that
> begin with " G4 "

The output of "printenv | grep G4" is the following:

G4LEVELGAMMADATA=/afs/cern.ch/sw/geant4/releases/share/data/PhotonEvaporation2.3
G4NEUTRONXSDATA=/afs/cern.ch/sw/geant4/releases/share/data/G4NEUTRONXS1.2
G4LEDATA=/afs/cern.ch/sw/geant4/releases/share/data/G4EMLOW6.32
G4NEUTRONHPDATA=/afs/cern.ch/sw/geant4/releases/share/data/G4NDL4.2
G4RADIOACTIVEDATA=/afs/cern.ch/sw/geant4/releases/share/data/RadioactiveDecay3.6
G4PIIDATA=/afs/cern.ch/sw/geant4/releases/share/data/G4PII1.3
G4SAIDXSDATA=/afs/cern.ch/sw/geant4/releases/share/data/G4SAIDDATA1.1
G4REALSURFACEDATA=/afs/cern.ch/sw/geant4/releases/share/data/RealSurface1.0
  
> It looks like you're using an LCG based installation, so did you install
> this, and if so how? If not, do you know how the Geant4 you are trying
> to build your application against was installed and configured?

Yes, I am using a LCG based installation on an AFS system, but I did not set it up myself and I unfortunately do not have any idea how Geant4 was installed or configured on this system. There are however a few setup scripts provided, all of which I source. To give some context, I am attempting to get my current application (which works fine on my personal computer) to run over AFS.

Thank you for the quick response. Let me know if you need any more information.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Error when linking to CLHEP library   (Ben Morgan - 21 Jan, 2013)
 Add Message Add Message
to: "Re: Error when linking to CLHEP library"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]