Message: Geant4 crashes when X-Rays are activated Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Geant4 crashes when X-Rays are activated 

Forum: Installation and Configuration
Date: 14 Dec, 2012
From: <Chris_>

Hi,

I switched from Geant 4 9.5 to Geant 4 9.6 today. My simulation (only EM interactions with G4EmLivermorePhysics) worked perfectly with Geant 4 9.5, but now I am having some trouble. Basically the simulations runs both with and without vizualiszation, but in both cases I can only simulated up to 1000 primary photons, if I try 2000 the simulation is stuck and I have to manually kill it. If I turn off the X-ray module I am able to simulate more primaries.

Also I get an error message when the simulation runs through with e.g. 100 photons at the end, which is:

*** glibc detected *** ./mySim: corrupted double-linked list:0x0000000001ca19a0 ***

My problem sound very much like this http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1512.html

Does anyone have an idea on what to do? Thank you!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Warning: Re: Geant4 crashes when X-Rays are activated   (Ben Morgan - 14 Dec, 2012)
 Add Message Add Message
to: "Geant4 crashes when X-Rays are activated"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]