Message: Re: Installing Geant4.9.5.p02 On RedHat - CMAKE error, Cant install! Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: Installing Geant4.9.5.p02 On RedHat - CMAKE error, Cant install! 

Forum: Installation and Configuration
Re: None Installing Geant4.9.5.p02 On RedHat - CMAKE error, Cant install! (Ben Hug)
Date: 08 Nov, 2012
From: Ben Morgan <Ben Morgan>

On Thu, 08 Nov 2012 05:34:28 GMT, Ben Hug wrote:
> Have downloaded the source file from the Geant4 website and unpacked
> this file into a directory called /root/Geant4Simulations in the
> directory geant4.9.4.p02
> 
> Have then created a build directory @ the following path:
> /root/Geant4Simulations/geant4.9.5-build
> 
> According to the instructions I am then meant to navigate into this
> build directory and then complete the following line: cmake
> -DCMAKE_INSTALL_PREFIX=/path/to/geant4.9.5-install /path/to/geant4.9.5
> 
> where I have substitued in: cmake
> -DCMAKE_INSTALL_PREFIX=/root/Geant4Simulations/geant4.9.5-install
> /root/Geant4Simulations/geant4.9.5.p02
> 
> When I run this line i get the following error:
> 
> CMake Error: The source directory
> "/root/Geant4Simulations/geant4.9.5.p02" does not appear to contain
> CMakeLists.txt.

The first thing to check is that the directory /root/Geant4Simulations/geant4.9.5.p02 is present, and contains a CMakeLists.txt. If those are both present, then it might be a permissions error with accessing the directory or file - you appear to be running as the root user though, which would tend to avoid this (however, you should not be running as root for day to day work!). If the directory and/or file are missing, check the directories which are present and their contents. You say you downloaded geant4.9.5.p02, but unpacked it in a directory geant4.9.4.p02 - it that isn't a typo I'd suspect that may be the cause!.

Cheers,

Ben.

 Add Message Add Message
to: "Re: Installing Geant4.9.5.p02 On RedHat - CMAKE error, Cant install!"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]