Message: Re: Fail to install GEANT 4 with Window XP Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Fail to install GEANT 4 with Window XP 

Forum: Installation and Configuration
Re: Question Fail to install GEANT 4 with Window XP (Gilmer Valdes)
Re: Question Re: Fail to install GEANT 4 with Window XP (Ben Morgan)
Re: Question Re: Fail to install GEANT 4 with Window XP (Gilmer Valdes)
Re: None Re: Fail to install GEANT 4 with Window XP (Ben Morgan)
Re: None Re: Fail to install GEANT 4 with Window XP (Kirk Bertsche)
Date: 25 Jan, 2013
From: Ben Morgan <Ben Morgan>

On Thu, 24 Jan 2013 16:26:39 GMT, Kirk Bertsche wrote:
> I'm having the same problem as described, but with Windows 7,
> Geant4.9.6, CMake GUI and Visual C++ 2010 Express.
> 
> When I try to run example B1, it aborts execution with a "fatal error:
> missing mandatory data for this simulation engine" after telling me to
> "please set the environment variable"(s) G4LEDATA, G4LEVELGAMMADATA, and
> G4NEUTRONXS to point to the correct directories.
> 
> I've installed multiple times, I've checked the "install data" box in
> CMake, I've explicitly added the data directory to CMake and to the
> Windows path. The data is all there, in the correct directory
> (C:/geant4/geant4_9_6-install/share/Geant4-9.6.0/data).
> 
> Any ideas?
> 

See Section 3.3 of the Installation Guide. Unfortunately, the configuration of the data environment variables needs to be done manually in Windows (though you can also wrap your application in a script to do this if you prefer).

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Fail to install GEANT 4 with Window XP   (Kirk Bertsche - 25 Jan, 2013)
 Add Message Add Message
to: "Re: Fail to install GEANT 4 with Window XP"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]