Message: Library problems OSX 10.8.2, 4.9.6.b01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Library problems OSX 10.8.2, 4.9.6.b01 

Forum: Installation and Configuration
Date: 26 Oct, 2012
From: Daniel Cox <Daniel Cox>

Hi. I've gotten myself a little problem with libraries, and can't seem to google my way out of it.

I install as per the guide with the following cmake

cmake \ -DCMAKE_INSTALL_PREFIX=/Applications/geant4.9.6/geant4.9.6.b01-install \ -DGEANT4_USE_OPENGL_X11=ON \ /Applications/geant4.9.6/geant4.9.6.b01/

No errors, seems to have installed fine.

Then I compile and run N02, I get this;

dyld: Library not loaded: /opt/local/lib/libX11.6.dylib
  Referenced from: /usr/local/lib/libXmu.6.dylib
  Reason: Incompatible library version: libXmu.6.dylib requires version 10.0.0 or later, but libX11.6.dylib provides version 9.0.0
Trace/BPT trap: 5

I have XQuartz 2.7.4, XCode 4.5.1, OSX 10.8.2, any ideas?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (John Allison - 26 Oct, 2012)
1 None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Daniel Cox - 26 Oct, 2012)
(_ None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (John Allison - 26 Oct, 2012)
(_ Question: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Daniel Cox - 26 Oct, 2012)
(_ None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (John Allison - 26 Oct, 2012)
(_ Feedback: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Ben Morgan - 26 Oct, 2012)
(_ None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Daniel Cox - 29 Oct, 2012)
(_ Feedback: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Ben Morgan - 29 Oct, 2012)
(_ None: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Daniel Cox - 29 Oct, 2012)
2 Question: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Batom - 04 Nov, 2012)
1 Question: Re: Library problems OSX 10.8.2, 4.9.6.b01   (Daniel Cox - 04 Nov, 2012)
 Add Message Add Message
to: "Library problems OSX 10.8.2, 4.9.6.b01"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]