Message: problem G4OpenGLXViewer::G4OpenGLXViewer Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None problem G4OpenGLXViewer::G4OpenGLXViewer 

Forum: Installation and Configuration
Date: 28 Sep, 2012
From: <gderosa@na.infn.it>

Hi!
I have problems with
G4OpenGLXViewer::G4OpenGLXViewer

I tried to install g4 following the instructions, but running
example/novice/N02 (default vis.mac) I got the following error message:


# Use this open statement to create an OpenGL view:
/vis/open OGL 600x600-0+0
/vis/sceneHandler/create OGL
/vis/viewer/create ! ! 600x600-0+0
G4OpenGLXViewer::G4OpenGLXViewer: unable to get a single buffer visual.
G4OpenGLXViewer::G4OpenGLXViewer: unable to get a double buffer visual.
G4OpenGLXViewer::G4OpenGLXViewer: unable to get required visuals.
G4OpenGLStoredX::CreateViewer: error flagged by negative view id in
G4OpenGLStoredXViewer creation.
 Destroying view and returning null pointer.
ERROR in G4VisManager::CreateViewer during OpenGLStoredX viewer creation.
  No action taken.
WARNING: No viewer created.
.......
.......

I see that this problem was already found in the past, but, also following
the suggestion proposed in the forum, I eas non able to solve the problem.

Do you have any hint?
thank in advances
Gianfranca

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: problem G4OpenGLXViewer::G4OpenGLXViewer   (Joseph Perl - 30 Sep, 2012)
2 None: Re: problem G4OpenGLXViewer::G4OpenGLXViewer   (Bethany - 11 Feb, 2013)
1 None: Re: problem G4OpenGLXViewer::G4OpenGLXViewer   (Joseph Perl - 11 Feb, 2013)
 Add Message Add Message
to: "problem G4OpenGLXViewer::G4OpenGLXViewer"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]