Message: Re: MPI interface wont compile in Geant4 9.5.p01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: MPI interface wont compile in Geant4 9.5.p01  

Forum: Installation and Configuration
Re: Question MPI interface wont compile in Geant4 9.5.p01 (Ali Ebrahimi)
Re: Feedback Re: MPI interface wont compile in Geant4 9.5.p01 (Ben Morgan)
Re: None Re: MPI interface wont compile in Geant4 9.5.p01 (Ali Ebrahimi)
Date: 08 Aug, 2012
From: Ben Morgan <Ben Morgan>

On Wed, 08 Aug 2012 07:58:39 GMT, Ali Ebrahimi wrote:
> Thank you for the the tip, I did it and then tried to compile it again.
> This time I get a new error: error: no matching function for call to
> �G4Exception(const char ... candidates are: ...
> 
> It seems the some of the files of the mpi interface are not updated in
> the latest release? If there is no way to fix this for the moment, is
> there any way I can run my application on a multi processor/multi core
> machine?

If this is not compiling using the GNUmakefile system, then it's worth submitting a Bug Report so that the example maintainers can check.

If your application is "embarrassingly parallel" then you can split it up into many subjobs, and you only need take care to seed the random number generator differently in each job. If it requires full parallelism, then we expect a release of Geant4-MT 9.5 within the next month.

Cheers,

Ben.

 Add Message Add Message
to: "Re: MPI interface wont compile in Geant4 9.5.p01 "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]