Message: Re: MPI interface wont compile in Geant4 9.5.p01 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: MPI interface wont compile in Geant4 9.5.p01  

Forum: Installation and Configuration
Re: Question MPI interface wont compile in Geant4 9.5.p01 (Ali Ebrahimi)
Re: Feedback Re: MPI interface wont compile in Geant4 9.5.p01 (Ben Morgan)
Date: 08 Aug, 2012
From: Ali Ebrahimi <Ali Ebrahimi>

> If you're building applications using the GNUmakefile interface, then
> you need to source the file
> 
> CMAKE_INSTALL_PREFIX/share/Geant4-9.5.1/geant4make/geant4make.sh
> 
> See also Section 3 (http://geant4.web.cern.ch/geant4/UserDocumentation/UsersGuides/InstallationGuide/html/ch03.html)
> of the Installation Guide.
> 
> As far as CMake goes, see this earlier thread (http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1478.html)
> .
> 
> Cheers,
> 
> Ben.

Thank you for the the tip, I did it and then tried to compile it again. This time I get a new error: error: no matching function for call to G4Exception(const char ... candidates are: ...

It seems the some of the files of the mpi interface are not updated in the latest release? If there is no way to fix this for the moment, is there any way I can run my application on a multi processor/multi core machine?

thanks a lot in advance, Ali

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: MPI interface wont compile in Geant4 9.5.p01   (Ben Morgan - 08 Aug, 2012)
 Add Message Add Message
to: "Re: MPI interface wont compile in Geant4 9.5.p01 "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]