Message: 4.9.4.p04 and 4.9.05 compilation problems Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question 4.9.4.p04 and 4.9.05 compilation problems 

Forum: Installation and Configuration
Date: 06 Jul, 2012
From: Steve Asztalos <Steve Asztalos>

Hi,

I have two compilation issue that are, in fact, related.

1) I installed and compiled 4.9.5.p01 under Ubuntu 12.04, but when I tried to run example N01 I got a run time error stating that it couldn't find my granular libraries. I then recompiled with the granular library flag set and still got the same complaint. What am I doing wrong?

2) I then went to my 4.9.4.p04 version, recompiled N01under this version to run the same example and got the runtime error below. Why does code compiled under 4.9.4.p04 think it's running geant4-09-05?

Can't the two versions coexist? Can I switch between the two?

Thanks - Steve

*************************************************************
 Geant4 version Name: geant4-09-05-patch-01    (20-March-2012)
                      Copyright : Geant4 Collaboration
                      Reference : NIM A 506 (2003), 250-303
                            WWW : http://cern.ch/geant4
*************************************************************

exampleN01: malloc.c:2451: sYSMALLOc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed. Aborted (core dumped)

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: Re: 4.9.4.p04 and 4.9.05 compilation problems   (William Webster - 07 Jul, 2012)
2 None: Re: 4.9.4.p04 and 4.9.05 compilation problems   (Ben Morgan - 09 Jul, 2012)
 Add Message Add Message
to: "4.9.4.p04 and 4.9.05 compilation problems"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]