Message: Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi 

Forum: Installation and Configuration
Re: None undefined symbol: _ZNK10QTabWidget14heightForWidthEi (Thomas D. Mays )
Date: 01 May, 2012
From: Ben Morgan <Ben Morgan>

On Tue, 01 May 2012 06:30:44 GMT, Thomas D. Mays  wrote:
> hi friends:
>   I just try to install GATE. I compiled qt-4.8.1 without mistake on ubuntu11.10.
>   The problem I encountered when type the command of starting GATE is the following:
> >>root@liubin-HP-ProBook-4416s:/home/liubin/simulation/gate6_1# Gate
> >>Gate: symbol lookup error: /home/liubin/simulation/geant4_9_4_p03/lib/Linux-g++/libG4interfaces.so: undefined symbol: _ZNK10QTabWidget14heightForWidthEi
> 
> Any one can help me ? I don't know how to deal with it . Thank you for
> advance
> 

I would suspect that if Geant4 and Gate compiled without error that the correct Qt library is not being loaded (I think it probably is finding a Qt library otherwise the error would be a missing library). You say that you compiled Qt yourself - is the path to those libraries in your LD_LIBRARY_PATH? Do you have any other version of Qt installed? You can check which libraries are being found by the application by running

$ LD_DEBUG=libs Gate

Provided Gate is an executable, that will print out fairly verbose information about which libraries are loaded - check that the Qt ones are those you compiled against.

Note that we can't support Gate here (or Ubuntu 11.10), but the problem does seem to be in Geant4 for now.

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi   (Thomas D. Mays - 01 May, 2012)
2 None: Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi   (Thomas D. Mays - 01 May, 2012)
1 None: Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi   (Ben Morgan - 01 May, 2012)
 Add Message Add Message
to: "Re: undefined symbol: _ZNK10QTabWidget14heightForWidthEi"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]