Message: Re: Geant 4.9.5p01 slower that Geant4.9.4.p02 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Geant 4.9.5p01 slower that Geant4.9.4.p02 

Forum: Installation and Configuration
Re: Feedback Geant 4.9.5p01 slower that Geant4.9.4.p02 (Jérôme Roccaz)
Date: 23 Apr, 2012
From: Ben Morgan <Ben Morgan>

On Mon, 23 Apr 2012 12:28:48 GMT, J�r�me Roccaz wrote:
> Hi everyone,
> 
> I've recently installed release 4.9.5.p01 and used release 4.9.4.p02. My
> OS is SL6.0 runnind under VMWare.
> 
> I've noticed that last release is globally slower :
> 
>   - when compiling, linking takes minutes whereas it takes few seconds with release 4.9.4.p02 (using granular libs)

Could you be a little more specific here? Do you mean linking of each Geant4 library when it is built (and if so which libraries?)? Or do you mean linking the Geant4 libraries to an application?

I don't see any major time penalties on my machines - how much resource does your VM have?

>   - execution of the same program is nearly twice slower
> 
> I had a look on that thread :
> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1433.html
> 
> Does it explain both items? If yes will it be soon corrected?

Not the first - linking should have nothing to do with runtime issues or leaks. You may wish to look at the fixed Bug 1286 to see if this relates, though that is memory rather than performance related. If you think you've found a major performance difference, please submit a Bugzilla report

Cheers,

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Geant 4.9.5p01 slower that Geant4.9.4.p02   (Jérôme Roccaz - 23 Apr, 2012)
 Add Message Add Message
to: "Re: Geant 4.9.5p01 slower that Geant4.9.4.p02"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]