Message: the FLAGS in the env.sh Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None the FLAGS in the env.sh 

Forum: Installation and Configuration
Date: 16 Apr, 2012
From: Thomas D. Mays <Thomas D. Mays >

This is a multi-part message in MIME format.
--------------000905050307020405070606
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

hi friends:

*/I don't know about the FLAGS, such as: XMFLAGS, XAWFLAGS, XERCESCROOT. I am installing the GATE6.1 system using geant4.9.4.p03.

I am not sure about the relation between these FLAGS and my GATE operation.

Are there errors in these FLAGS "XMFLAGS, XAWFLAGS, XERCESCROOT"?,because  the flags's value is missing. How should I deal with that?/*

the following is detail output  by typing the command*/  _source  env_gate.sh_/*  :
  

On this machine the CLHEP_LIB_DIR=/home/liubin/simulation/CLHEP_2_1_0_1/lib

On this machine the CLHEP_LIB=CLHEP

On this machine the G4UI_USE_TCSH=1

On this machine the G4UI_BUILD_XAW_SESSION=1

On this machine the G4UI_USE_XAW=1

On this machine the G4UI_BUILD_XM_SESSION=1

On this machine the G4UI_USE_XM=1

On this machine the G4UI_BUILD_QT_SESSION=1

On this machine the G4UI_USE_QT=1

On this machine the G4VIS_BUILD_DAWN_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLXM_DRIVER=1

On this machine the G4VIS_BUILD_RAYTRACERX_DRIVER=1

On this machine the G4VIS_BUILD_VRML_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLQT_DRIVER=1

On this machine the G4VIS_USE_DAWN=1

On this machine the G4VIS_USE_OPENGLX=1

On this machine the G4VIS_USE_OPENGLXM=1

On this machine the G4VIS_USE_RAYTRACERX=1

On this machine the G4VIS_USE_VRML=1

On this machine the G4VIS_USE_OPENGLQT=1

On this machine the XMFLAGS=

On this machine the XMLIBS= -lXm -lXpm

On this machine the XMFLAGS=

On this machine the XAWFLAGS=

On this machine the XAWLIBS= -lXaw

On this machine the QTMOC=/usr/include/qt4/bin/moc

On this machine the QTFLAGS=-I/usr/include/qt4/include -I/usr/include/qt4/include/QtCore -I/usr/include/qt4/include/QtGui  -I/usr/include/qt4/include/QtOpenGL

On this machine the QTLIBS=-L/usr/include/qt4/lib -lQtCore -lQtGui

On this machine the GLQTLIBS=-L/usr/include/qt4/lib -lQtCore -lQtGui -lQtOpenGL

On this machine the G4LIB_BUILD_GDML=1

On this machine the XERCESCROOT=

On this machine the G4LIB_BUILD_G3TOG4=1

On this machine the G4LIB_USE_G3TOG4=1

On this machine the G4LIB_BUILD_ZLIB=1

On this machine the G4LIB_USE_ZLIB=1

On this machine the G4LIB_BUILD_SHARED=1



On this machine the G4LIB_BUILD_STATIC=1


--------------000905050307020405070606
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <pre wrap="">
<font color="#000000">hi friends:</font>

<b><i>I don't know about the FLAGS, such as: XMFLAGS, XAWFLAGS, XERCESCROOT. I am installing the GATE6.1 system using geant4.9.4.p03. 

I am not sure about the relation between these FLAGS and my GATE operation.
<font color="#ff0000">
Are there errors in these FLAGS "</font>XMFLAGS, XAWFLAGS, XERCESCROOT <font color="#ff0000">" </font>?,because  the flags's value is missing. How should I deal with that?</i></b>

<font color="#ff0000">the following is detail output  by typing the command </font><b><i> <u>source  env_gate.sh  </u></i></b> <font color="#ff0000">:</font>
<font color="#ff0000"> </font>

On this machine the CLHEP_LIB_DIR=/home/liubin/simulation/CLHEP_2_1_0_1/lib

On this machine the CLHEP_LIB=CLHEP

On this machine the G4UI_USE_TCSH=1

On this machine the G4UI_BUILD_XAW_SESSION=1

On this machine the G4UI_USE_XAW=1

On this machine the G4UI_BUILD_XM_SESSION=1

On this machine the G4UI_USE_XM=1

On this machine the G4UI_BUILD_QT_SESSION=1

On this machine the G4UI_USE_QT=1

On this machine the G4VIS_BUILD_DAWN_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLXM_DRIVER=1

On this machine the G4VIS_BUILD_RAYTRACERX_DRIVER=1

On this machine the G4VIS_BUILD_VRML_DRIVER=1

On this machine the G4VIS_BUILD_OPENGLQT_DRIVER=1

On this machine the G4VIS_USE_DAWN=1

On this machine the G4VIS_USE_OPENGLX=1

On this machine the G4VIS_USE_OPENGLXM=1

On this machine the G4VIS_USE_RAYTRACERX=1

On this machine the G4VIS_USE_VRML=1

On this machine the G4VIS_USE_OPENGLQT=1

<font color="#ff0000">On this machine the XMFLAGS=</font>

On this machine the XMLIBS= -lXm -lXpm 

<font color="#ff0000">On this machine the XMFLAGS=</font>

<font color="#ff0000">On this machine the XAWFLAGS=</font>

On this machine the XAWLIBS= -lXaw 

On this machine the QTMOC=/usr/include/qt4/bin/moc

On this machine the QTFLAGS=-I/usr/include/qt4/include -I/usr/include/qt4/include/QtCore -I/usr/include/qt4/include/QtGui  -I/usr/include/qt4/include/QtOpenGL

On this machine the QTLIBS=-L/usr/include/qt4/lib -lQtCore -lQtGui

On this machine the GLQTLIBS=-L/usr/include/qt4/lib -lQtCore -lQtGui -lQtOpenGL

On this machine the G4LIB_BUILD_GDML=1
<font color="#ff0000">
On this machine the XERCESCROOT=</font>

On this machine the G4LIB_BUILD_G3TOG4=1

On this machine the G4LIB_USE_G3TOG4=1

On this machine the G4LIB_BUILD_ZLIB=1

On this machine the G4LIB_USE_ZLIB=1

On this machine the G4LIB_BUILD_SHARED=1

 

On this machine the G4LIB_BUILD_STATIC=1
</pre>
  </body>
</html>

--------------000905050307020405070606--

 Add Message Add Message
to: "the FLAGS in the env.sh"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]