Message: Re: aTrackAllocator error geant4.9.4p03 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: aTrackAllocator error geant4.9.4p03 

Forum: Installation and Configuration
Re: Question aTrackAllocator error geant4.9.4p03 (ismet)
Re: None Re: aTrackAllocator error geant4.9.4p03 (Ben Morgan)
Re: Question Re: aTrackAllocator error geant4.9.4p03 (ismet)
Re: None Re: aTrackAllocator error geant4.9.4p03 (Michael H. Kelsey)
Date: 18 Apr, 2012
From: ismet <ismet>

Thanks again..

I have now tried to install the dev version of the library packages, and now they can recognized the lib for XAW and X11-Motif..
But, it cannot recognize the Qtcore lib
below is the comment




Enable building of the Qt UI module? [n] y
checking for qglobal.h... /usr/include/qt4/QtCore/qglobal.h
checking Qt major version... 4
checking for QtGui headers... yes
checking for QtOpenGL headers... yes
checking for QtCore library... no
checking for moc... /usr/bin/moc-qt4
./qt: 508: x: not found

Autodetection failed to locate Qt4 in on your system.
Please enter the path to your Qt4 install (i.e. if Qt4 is installed
in PATH/include/QT, PATH/include or PATH/include/qt4, enter PATH),
or type '-' to CANCEL the build of the Qt UI module.
Qt path:





I could find the dev version of libqt4-core, therefore I can only install libqt4-core

any idea how i solve this problem ??


btw, when I install everything the Gate still give the same comment


Gate: symbol lookup error: /home/ismet/geant4.9.4.p03/lib/Linux-g++/libG4tracking.so: undefined symbol: aTouchableHistoryAllocator



regards




 On Tue, 17 Apr 2012 21:33:57 GMT, Michael H. Kelsey wrote:
> On Tue, 17 Apr 2012 02:38:24 GMT, ismet wrote:
>
> > On Mon, 16 Apr 2012 16:38:27 GMT, Ben Morgan wrote:
> >
> > > On Tue, 10 Apr 2012 01:06:08 GMT, ismet wrote:
> > > > And for the OPTIONS FOR GEANT4 OPTIONAL EXTENSION MODULES* I have to
> > > > cancelled it, because they could not find some of the files..
> > >
> > > I *think* you probably don't have the required packages installed on
> > > your system required by these modules. I'm afraid I don't have a
> > > complete list of the required packages on Ubuntu 11.10, but if you
> > > search in Synaptic or on the the Ubuntu packages index (http://packages.ubuntu.com)
> > > for things like Xaw and Qt, they should be fairly obvious. Note though
> > > that you will also need the "dev/devel" packages - these should be
> > > listed along with the others.
> >
> > Thanks for your reply..
> >
> > I have tried to update those packages, in fact some of them are
> > installed already.I then tried to re-install the Geant4 again, and when
> > it comes to the question about Qt and XAW, it always says that it cannot
> > find it in the expected place, while I saw that those libraries (libXaw7
> > , libqt4 etc) are already there in /usr/lib directory
> >
> > Any idea why they cannot recognize these packages ??????
>
> As Ben noted, you need to have the "dev" or "devel" version of those
> packages. Even if you appear to already have them installed on your
> system, make sure that what you have are the "developer" versions, and
> reinstall the latter as necessary.
>
> The GEANT4 visualization code references some X11 and Qt header files
> which are not normally installed with the "general user" packages,
> because the latter assume that you're just running executables which
> somebody else built.
>

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: aTrackAllocator error geant4.9.4p03   (ismet - 18 Apr, 2012)
2 Note: Re: aTrackAllocator error geant4.9.4p03   (Ben Morgan - 19 Apr, 2012)
1 None: Re: aTrackAllocator error geant4.9.4p03   (ismet - 19 Apr, 2012)
 Add Message Add Message
to: "Re: aTrackAllocator error geant4.9.4p03"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]