Message: Re: bsub problems with geant4 9.5 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

News Re: bsub problems with geant4 9.5 

Forum: Installation and Configuration
Re: Question bsub problems with geant4 9.5 (J.Ostariz)
Date: 09 Mar, 2012
From: Ben Morgan <Ben Morgan>

On Wed, 07 Mar 2012 12:13:46 GMT, J.Ostariz wrote: 
> /afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim:
> /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required
> by /afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim)
> 
> /afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim:
> /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required
> by
> /afs/cern.ch/sw/lcg/external/geant4/9.5/x86_64-slc5-gcc43/lib/libG4Tree.so)
> 
> ...
> 
> Any idea of how to fix this??
> 
> Thank you
> 

This isn't a Geant4 problem as such - it looks like there's some missing configuration when you submit your job. On lxplus, you add the LCG version of gcc (and hence libstdc++.so.6) to your LD_LIBRARY_PATH, and I assume that's the version of gcc that the LCG Geant4 is built against.

Looking at the output of your batch job, the program/library are picking up the system libstdc++.so.6 - and that looks like it is an older version (and hence incompatible) with that required by Geant4/your application. I'd suggest checking that your job submission sets up the environment correctly - in other words, that the LD_LIBRARY_PATH is the same as wehn you run interactively on lxplus.

Hope that helps,

Ben.

 Add Message Add Message
to: "Re: bsub problems with geant4 9.5"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]