Message: bsub problems with geant4 9.5 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question bsub problems with geant4 9.5 

Forum: Installation and Configuration
Date: 07 Mar, 2012
From: J.Ostariz <J.Ostariz>

Hi everybody,

I updated to geant4 9.5 version in lxplus.

My bash_profile is:

source "/afs/cern.ch/sw/lcg/contrib/gcc/4.3/x86_64-slc5-gcc43-opt/setup.sh"

export LD_LIBRARY_PATH=/afs/cern.ch/sw/lcg/contrib/gcc/4.3.2/x86_64-slc5-gcc43-opt/lib64:$LD_LIBRARY_PATH

export LD_LIBRARY_PATH=/afs/cern.ch/sw/lcg/contrib/gcc/4.3.2/x86_64-slc5-gcc43-opt/lib:$LD_LIBRARY_PATH

export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH

export OGLHOME="/usr/"

export OGLLIBS="-L/usr/lib64 -lGLU -lGL"

export LD_LIBRARY_PATH=$OGLHOME/lib64:$OGLLIBS:${LD_LIBRARY_PATH}

uname -a: Linux lxplus420.cern.ch 2.6.18-274.18.1.el5 #1 SMP Fri Feb 10 14:14:58 CET 2012 x86_64 x86_64 x86_64 GNU/Linux

and gcc --version, g++ --version:
  g++ (GCC) 4.3.2
  gcc (GCC) 4.3.2

No problems while compiling. I can run my geant4 application in the lxplus nodes, but when I try to run it as a batch job via bsub command, I get this error message.

/afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim)

/afs/cern.ch/user/j/jgraciag/g4work/bin/Linux-g++/mMSim: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /afs/cern.ch/sw/lcg/external/geant4/9.5/x86_64-slc5-gcc43/lib/libG4Tree.so)

...

Any idea of how to fix this??

Thank you

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 News: Re: bsub problems with geant4 9.5   (Ben Morgan - 09 Mar, 2012)
 Add Message Add Message
to: "bsub problems with geant4 9.5"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]