Message: Re: Having trouble with OpenGL. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Having trouble with OpenGL. 

Forum: Installation and Configuration
Re: Question Having trouble with OpenGL. (Adam Spindler)
Date: 14 Feb, 2012
From: Ben Morgan <Ben Morgan>

Hi Adam,

On Tue, 14 Feb 2012 11:18:42 GMT, Adam Spindler wrote:
> Upon running the Make Command, The system runs through all the build
> processes and then does this -
> 
> Linking CXX shared library
> ../../../outputs/library/Linux-g++/libG4OpenGL.so /usr/bin/ld: cannot
> find -lOFF collect2: ld returned 1 exit status make[2]: ***
> [outputs/library/Linux-g++/libG4OpenGL.so] Error 1 make[1]: ***
> [source/visualization/OpenGL/CMakeFiles/G4OpenGL.dir/all] Error 2 make:
> *** [all] Error 2

The suspicious thing here is the -lOFF, as I'm not aware of any libOFF in 11.10 (though I don't have a box to hand right now). Could you rebuild (you don't need to from scratch, just from the failing build directory) using:

$ make G4OpenGL VERBOSE=1

and post the link command that results in the error please? I suspect there's something odd in the configuration that has promoted a CMake option (hence the OFF) to a library name. You could also check through the CMakeCache.txt file in your build directory and see where OFF appears, especially in any X11_ and OPENGL_ variables.

Cheers,

Ben.

 Add Message Add Message
to: "Re: Having trouble with OpenGL."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]