Message: Problem with cmake on Mac, Geant 4.9.5 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Problem with cmake on Mac, Geant 4.9.5 

Forum: Installation and Configuration
Date: 10 Feb, 2012
From: Milan Matos <Milan Matos>

Hello, I am trying to install Geant 4.9.5 from source on intel MacBook Pro running Snow Leopard 10.6, cmake version 2.8.7, gcc version i686-apple-darwin10-gcc-4.2.1, g++ version i686-apple-darwin10-g++-4.2.1. If I go through the Geant4 Installation Guide and run cmake, it stops with an error, not able to find G4AdjointProcessEquivalentToDirectProcess.cc. This file really does not exist. However, G4AdjointProcessEquivalentToDirectProcess.c does, but it says t cannot find it even after trying different extensions.

Here are the printouts:

xxxxx:~/soft/Geant/geant4.9.5-build$ cmake -DCMAKE_INSTALL_PREFIX=/Users/xxxxx/soft/Geant/geant4.9.5-install /Users/xxxxx/soft/Geant/geant4.9.5

......

-- Configuring done
CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:70 (add_library):
  Cannot find source file:
    /Users/xxxxx/soft/Geant/geant4.9.5/source/processes/electromagnetic/adjoint/src/G4AdjointProcessEquivalentToDirectProcess.cc
  Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
  .hxx .in .txx
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:253 (GEANT4_LIBRARY_TARGET)
  source/processes/CMakeLists.txt:34 (GEANT4_GLOBAL_LIBRARY_TARGET)

Any idea what could be the problem? Thank you Milan

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Problem with cmake on Mac, Geant 4.9.5   (Tom Roberts - 10 Feb, 2012)
1 None: Re: Problem with cmake on Mac, Geant 4.9.5   (Milan Matos - 10 Feb, 2012)
2 Question: Re: Problem with cmake on Mac, Geant 4.9.5   (James Howard - 11 Apr, 2012)
1 Note: Re: Problem with cmake on Mac, Geant 4.9.5   (Ben Morgan - 16 Apr, 2012)
 Add Message Add Message
to: "Problem with cmake on Mac, Geant 4.9.5"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]