Message: Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant? 

Forum: Installation and Configuration
Re: Question How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant? (Erik Dietz-Laursonn)
Re: None Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant? (John Allison)
Date: 13 Feb, 2012
From: Erik Dietz-Laursonn <Erik Dietz-Laursonn>

Dear John,
thanks for answering. The procedure you describe

- building Geant with cmake
- sourcing geant4.sh
- sourcing geant4make.sh
- switching vis drivers (export G4UI_USE_TCSH=1   unset G4UI_USE_QT)
- building application

seems to be the procedure to be chosen if your application is build via a GNUmakefile. In this case it works for my application. But I wanted to switch my application to cmake, too, as it is recommended. In this case, switching vis drivers as described above does not have any influence and my application always runs with qt. Do you have an idea how to solve this problem?

Best regardes,
Erik

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant?   (Tom Roberts - 13 Feb, 2012)
(_ None: Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant?   (John Allison - 13 Feb, 2012)
 Add Message Add Message
to: "Re: How to switch the used visualisation tool of a Geant4 simulation for cmake-installed Geant?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]